Aller au contenu


Photo

Lancement des MACs Virtuelles


  • Please log in to reply
85 replies to this topic

#41 mikmak

mikmak

    Advanced Member

  • Administrators
  • 383 Messages :

Posté 27 janvier 2011 - 22:26

donnez-moi le SD et éventuellement un compte sur les machines pour que je regarde

Mik

#42 Marc D.

Marc D.

    Member

  • Members
  • PipPip
  • 27 Messages :

Posté 27 janvier 2011 - 22:31

Je viens de trouver l'origine du problème, le dedibox ED possède 2 connections réseau dont une inactive
Connexion au réseau local : inactive
Connexion au réseau local 2 : active

J'avais configuré la connexion réseau d'hyper-v sur la 1ère interface réseau qui n'était pas connecté au réseau.
Ça ne risqué donc pas de marcher.

#43 Loic

Loic

    Newbie

  • Members
  • Pip
  • 3 Messages :

Posté 28 janvier 2011 - 10:51

Bonjour,

Nouveau sur ce forum, je ne suis pas encore client Dédibox.
J'aimerais savoir si le programme Béta est encore ouvert.
Par exemple, si je commande une Dédibox EG maintenant, puis-je tester VMWARE ESXi ?

D'avance merci

Loïc Tignon

#44 mikmak

mikmak

    Advanced Member

  • Administrators
  • 383 Messages :

Posté 28 janvier 2011 - 14:42

la beta est terminée, les MACs virtuelles sont accessibles à tous

Mik

#45 Loic

Loic

    Newbie

  • Members
  • Pip
  • 3 Messages :

Posté 28 janvier 2011 - 15:38

Merci Mik pour la rapidité de réponse.
Je m'en vais commander de ce pas.

Loïc

#46 Digital Media

Digital Media

    Newbie

  • Members
  • Pip
  • 8 Messages :

Posté 31 janvier 2011 - 12:25

Merci mikmak pour nous en avoir fait profiter.

#47 jtreves

jtreves

    Advanced Member

  • Members
  • PipPipPip
  • 1 039 Messages :

Posté 31 janvier 2011 - 13:53

Je viens de faire un test HyperV + VM sur un nouveau MG (livré en 7 minutes vendredi soir !). Cela a fonctionné du premier coup. Mon problème avec la DediPro V2 venait donc bien d'un problème de paramétrage du routeur et pas d'une mauvais configuration de ma part.

Jack

#48 mikmak

mikmak

    Advanced Member

  • Administrators
  • 383 Messages :

Posté 31 janvier 2011 - 14:31

t'es sur que tu choisissais le bon port réseau pour le bridge ?

cf un post précédent ou le premier de la liste n'était pas le port actif.

en tout cas il n'y a strictement aucune diff niveau réseau...

Mik

#49 jtreves

jtreves

    Advanced Member

  • Members
  • PipPipPip
  • 1 039 Messages :

Posté 31 janvier 2011 - 14:46

Oui, j'en suis sûr !

Et en plus j'ai refait 2 fois l'installation, la 2ème fois après avoir réinstallé Windows.

Jack

#50 LebPekin

LebPekin

    Newbie

  • Members
  • Pip
  • 1 Messages :

Posté 02 février 2011 - 14:43

Bonjour,

Quelqu'un a déjà réussi à utiliser ces VMACs en mode bridge sous Proxmox ?

Pas de communication (ping, etc down), tous les paquets passent en drop....

Merci

#51 neteyes

neteyes

    Member

  • Members
  • PipPip
  • 12 Messages :

Posté 03 février 2011 - 14:05

bonjour, j'ai un dédié avec ubuntu 10.4, j'ai installer wmware player 3.1
tout fonctionne a merveille.
j'aimerai pouvoir atribuer une ip faillover, pour chaque machine virtuelle.
merci

j'ai donc commander les ip faillover (2 pour commencer)
j'ai activé et atribuer une ipfaillover a une mac virtuel dans l'interface online.
j'ai atribuer une mac virtuelle a la carte reseau de ma machine virtuelle
j'ai modifié le fichier /etc/network/interface

avec la commande ifconfig -a j'optient ceci:

eth0 Link encap:Ethernet HWaddr 00:26:b9:xx:xx:xx
inet adr:88.190.xx.xx Bcast:88.190.xx.xx Masque:255.255.255.0
adr inet6: fe80::226:xx:xx:xx/64 Scope:Lien
UP BROADCAST RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
Packets reçus:250 erreurs:0 :0 overruns:0 frame:0
TX packets:268 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:25868 (25.8 KB) Octets transmis:45861 (45.8 KB)
Interruption:16 Mémoire:da000000-da012800

eth0:0 Link encap:Ethernet HWaddr 00:26:b9:xx:xx:xx
inet adr:88.190.yy.yy Bcast:88.190.yy.yy Masque:255.255.255.0
UP BROADCAST RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
Interruption:16 Mémoire:da000000-da012800

eth0:1 Link encap:Ethernet HWaddr 00:26:b9:xx:xx:xx
inet adr:88.190.zz.zz Bcast:88.190.zz.zz Masque:255.255.255.0
UP BROADCAST RUNNING ALLMULTI MULTICAST MTU:1500 Metric:1
Interruption:16 Mémoire:da000000-da012800

eth1 Link encap:Ethernet HWaddr 00:26:b9:xx:xx:xx
UP BROADCAST MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)
Interruption:17 Mémoire:dc000000-dc012800

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
Packets reçus:77168 erreurs:0 :0 overruns:0 frame:0
TX packets:77168 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
Octets reçus:11718842 (11.7 MB) Octets transmis:11718842 (11.7 MB)

vmnet1 Link encap:Ethernet HWaddr 00:50:56:c0:00:01
inet adr:192.168.58.1 Bcast:192.168.58.255 Masque:255.255.255.0
adr inet6: fe80::250:56ff:fec0:1/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

vmnet8 Link encap:Ethernet HWaddr 00:50:56:c0:00:08
inet adr:172.16.191.1 Bcast:172.16.191.255 Masque:255.255.255.0
adr inet6: fe80::250:56ff:fec0:8/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
Packets reçus:807 erreurs:0 :0 overruns:0 frame:0
TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
Octets reçus:0 (0.0 B) Octets transmis:0 (0.0 B)

et route -n me donne cela:

Table de routage IP du noyau
Destination Passerelle Genmask Indic Metric Ref Use Iface
88.190.yy.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
88.190.zz.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
88.190.xx.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
172.16.191.0 0.0.0.0 255.255.255.0 U 0 0 0 vmnet8
192.168.58.0 0.0.0.0 255.255.255.0 U 0 0 0 vmnet1
169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 eth0
0.0.0.0 88.190.xx.1 0.0.0.0 UG 100 0 0 eth0

#52 neteyes

neteyes

    Member

  • Members
  • PipPip
  • 12 Messages :

Posté 05 février 2011 - 09:30

bonjour, comment je peux faire pour que les ip faillover soit attribuer aux pc virtuel.

en bridge, sa me donne une config ip sur la machine virtuelle qui ne fonctionne pas.
je but que sur sa, grrrrrrrrrr.

je ping depuis l’extérieur mes ip faillover sans problème.
quand je vais dans la config ip de la vm, j'ai bien la mac que j'ai creer dans l'interface online.
en nat, mes machines virtuelles ont accé au net.
mais je n'arrive pas a faire en sorte qu'au démarrage des vm, il lui soit attribuer l'ip faillover couplé a sa mac.

svp, je suis sur que c'est juste un paramètre a configurer, et la je galère, je trouve pas l'info sur le net.

merci encore

#53 blackwolfcds

blackwolfcds

    Advanced Member

  • Members
  • PipPipPip
  • 137 Messages :

Posté 06 février 2011 - 02:37

Bonsoir,

Pour une VM Linux, pour ma part je procède en trois étapes pour avoir le réseau opérationnel au démarrage.

Exemple pour une VM debian

Ce qui suit suppose que la configuration de l'hôte pour la couche de virtualisation, notamment l'association MAC/IPFO, est correcte.

1 - La config de l'interface réseau
Editer le fichier de config réseau ("vi /etc/network/interfaces")
Je me limite qu'a ces lignes pour l'interface eth0:
auto eth0
iface eth0 inet static
address IP-FAILOVER
netmask 255.255.255.255
Remplacer IP-FAILOVER par l'ip failover...

2 - Editer le fichier de config dns ("vi /etc/resolv.conf")
nameserver IPSERVERDNS
Remplacer IPSERVERDNS par l'ip du dns du serveur (normalement 88.190.254.XXX)

3 - Ajout des commandes de routages directement dans rc.local ("vi /etc/rc.local")
rc.local contient des commandes qui sont exécutées automatiquement au démarrage de la machine.
Ce fichier n'est pas tellement standard; par exemple, avec OpenSuse, c'est "/etc/rc.d/boot.local" qu'il faut modifier.

ifconfig eth0 IP-FAILOVER netmask 255.255.255.255 up
route add -host GATEWAYDEDIBOX dev eth0
route add default gw GATEWAYDEDIBOX

Remplacer bien sur "GATEWAYDEDIBOX" par l'ip de la passerelle du serveur (88.190.XXX.1)

C'est le seul moyen fonctionnel que j'ai trouvé pour que le réseau fonctionne au démarrage à coup sur.
Je n'ai jamais eu le réseau en entrant ces paramètres dans "/etc/network/interfaces".

-----------------------------------------------------------------------

Avec ces 3 étapes, cela fonctionne à tous les coups.
Je précise que j'utilise VMWare Server installé sur un Windows 2008, mais cela est normalement sans incidence sur la configuration de la VM.
Testé et approuvé sur Debian, Ubuntu, OpenSuse, Fedora et CentOS.
Suivant les distributions linux, les fichiers à éditer et leurs emplacements peuvent être différents. (google pour avoir les correspondances)
Les exemples fonctionne tels quels sur Debian-like (ubuntu...).

Sinon, je ne croit pas l'avoir vu dans ce fil, mais il est important de noter que dans le cas d'une VM windows (antérieure à 2003R2), lorsque l'on édite la base de registre pour modifier le masque, il faut mettre 255.255.255.255 partout, même pour le masque du serveur DNS.
J'ai galèré à cause ça, et je ne pense pas être le seul a avoir rencontré ce problème (VM qui ping comme un charme, mais pas d'internet).
Et aussi, ne pas se limiter à une seule modif, et abuser de F3 pour bien scanner la base de registre.

#54 jtreves

jtreves

    Advanced Member

  • Members
  • PipPipPip
  • 1 039 Messages :

Posté 06 février 2011 - 10:07

Sinon, je ne croit pas l'avoir vu dans ce fil, mais il est important de noter que dans le cas d'une VM windows, lorsque l'on édite la base de registre pour modifier le masque, il faut mettre 255.255.255.255 partout, même pour le masque du serveur DNS.
J'ai galèré à cause ça, et je ne pense pas être le seul a avoir rencontré ce problème (VM qui ping comme un charme, mais pas d'internet).
Et aussi, ne pas se limiter à une seule modif, et abuser de F3 pour bien scanner la base de registre.


Je l'ai déjà écrit à plusieurs reprises, depuis Windows 2003R2, il est inutile de taper dans la base de registre. On peut très bien mettre un masque de 255.255.255.255 dans les propriétés de la connexion et cela fonctionne très bien.

Jack

#55 neteyes

neteyes

    Member

  • Members
  • PipPip
  • 12 Messages :

Posté 06 février 2011 - 10:23

merci a vous pour vos réponses.

donc si je comprend bien, on met la carte réseau de la vm en bridge et on configure en dur la config ip de la vm.

exemple:

ubuntu + wmware player. ubuntu étant l’hôte et le logiciel de virtualisation étant vmware player.

pour une vm linux, mètre la carte en mode bridge et faire les modif dans les fichier comme indiqué plus haut.
pour une vm windows, mètre la carte en mode bridge et faire la config en ip fixe, avec un mask 255.255.255.255

je test de se pas..... a suivre

net

#56 blackwolfcds

blackwolfcds

    Advanced Member

  • Members
  • PipPipPip
  • 137 Messages :

Posté 06 février 2011 - 10:36

@jtreves -> Merci pour l'info; pas essayé 2003R2, mais pour 2008R2 j'avoue que j'ai commencé par modifier la bdr sans me soucier si cela pouvait fonctionner en natif.
Bref la méthode reste valable pour 2003/2000 (XP, Me, 98 etc...)


@neteyes -> C'est tout à fait ça.
Attention avant de mettre la carte en mode bridge de bien avoir une IPFO avec MAC virtuelle de configurée (depuis la console Online), autrement tu risque (c'est même sûr) de mettre ton serveur hors service.

#57 Digital Media

Digital Media

    Newbie

  • Members
  • Pip
  • 8 Messages :

Posté 06 février 2011 - 13:36

Si vous regardez mon post assez détaillé dans le cas de VM sur Win en host, on fait tourner autant du nux que du windows en 3-4 lignes et sans passer par le registre également.

#58 neteyes

neteyes

    Member

  • Members
  • PipPip
  • 12 Messages :

Posté 06 février 2011 - 14:23

merci pour les precisions.

retour de test:
j'ai mis ma wm en bridge, configuration ip en fixe
adresse ip = ip faillover couplé a la mac de la vm
mask= 255.255.255.255
passerelle= gateway du server (idem ip server mais se termine par .1)
dns = les dns du server

premier resultat, erreur ip en double sur le reseau, et passerelle pas dans le meme reseau.

j'ai suprimer les lignes dans le fichier "interface" eth0.0 et eth0.1 plu d'erreur.

mais je n'est pas accé a internet, je ping pas la passerelle, a mon avis j'oubli un pti quelque chose sur la config reseau de l'hote.

merci encore pour votre aide

net

#59 jtreves

jtreves

    Advanced Member

  • Members
  • PipPipPip
  • 1 039 Messages :

Posté 06 février 2011 - 14:38

merci pour les precisions.

retour de test:
j'ai mis ma wm en bridge, configuration ip en fixe
adresse ip = ip faillover couplé a la mac de la vm
mask= 255.255.255.255
passerelle= gateway du server (idem ip server mais se termine par .1)
dns = les dns du server

premier resultat, erreur ip en double sur le reseau, et passerelle pas dans le meme reseau.

j'ai suprimer les lignes dans le fichier "interface" eth0.0 et eth0.1 plu d'erreur.

mais je n'est pas accé a internet, je ping pas la passerelle, a mon avis j'oubli un pti quelque chose sur la config reseau de l'hote.

Je ne connais pas la configuration Linux + Vmware. Mais le message d'erreur passerelle pas sur le même réseau est normal. On peut l'ignorer. Le message IP en double signifie probablement que l'IP FO est également déclaré sur le Host et elle ne doit être déclaré que sur la VM (en tout c'est comme cela avec HyperV)

#60 neteyes

neteyes

    Member

  • Members
  • PipPip
  • 12 Messages :

Posté 06 février 2011 - 15:01

se que je ne comprend pas, c'est comment je peux avoir accès a la passerelle si je la ping pas depuis la vm??

vu que la passerelle n'est pas dans le même réseau, je la vois pas depuis la vm.

je pense que la complication viens du fait de vouloir des vm windows, sur un hôte linux.
en tout cas manque pas grand chose pour que sa fonctionne.

je continu mes tests je vous tiens au courant.

net




0 utilisateur(s) en train de lire ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)